Monthly Archives: November 2014

AppFabric 1.1 error while installing SharePoint Server 2013 prerequisites

SharePoint 2013

While installing the SharePoint Server 2013 prerequisites, you see the following error in the event log and the setup log:

Product: AppFabric 1.1 for Windows Server — Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action Env_PSModulePath_powershell_i, location: c:\Program Files\AppFabric 1.1 for Windows Server\Microsoft.ApplicationServer.InstallHelper.exe, command: powershell.exe “-command \”$str = [System.Environment]::GetEnvironmentVariable( \\\”PSModulePath\\\ “, [System.EnvironmentVariableTarget]::Machine); $str = $str+\\\”;c:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules\\\”; c:\Windows\system32\setx.exe /M PSModulePath \\\”$str\\\”\ “” “C:\Users\Administrator\AppData\Local\Temp\AppServerSetup1_1_CustomActions(2014-5-15 11-08-45).log”

CAUSE
The PSModulePath environment variable is corrupted. There is a quotation mark at the end.

C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\PowerShell\Modules;c:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules”

FIX
Delete the ending quotation mark and re-run the setup.

Original Official post here.